Баг "Wrong mod detected"

Discussion in 'IL-2 Sturmovik (Rus)' started by -=RFF=-Avva, Mar 12, 2009.

  1. -=RFF=-Avva

    -=RFF=-Avva Member

    Joined:
    Feb 11, 2009
    Messages:
    23
    Баг "Wrong mod detected"

    Дорогие разработчики! (Бармал?)

    Хотелось бы понять - вы в курсе, что баг защиты от читов мешает жить до сих пор? Суть я уже объяснял месяц назад или даже больше: первый раз на сервер заход нормальный. Если полетать немного и отсоединиться - то второй раз на сервер зайти уже невозможно: после ввода пароля HDD хрюкает секунд 10 и появляется сообщение "Wrong mod detected".
    Помогает только перезагрузка Windows.

    Более того - если даже перезагрузиться и запустить Ил2 не сразу после ребута, а сначала запустить браузер (Maxthon) и IL2_Connect - сообщение "Wrong mod detected" получаем на первой же попытке присоединения к серверу после ввода пароля...

    Это явно глюк защиты - обычный Ил2 цепляется на любые серваки с ЧРТ=2 и без.

    Моя система:
    Windows XP x64, один единственный раздел C: на весь HDD емкостью 80ГБ, файловая система NTFS.


    Исправьте пожалуйста, а? Очень напрягает необходимость каждый раз перезагружаться...
     
  2. lilija

    lilija Well-Known Member

    Joined:
    Nov 17, 2001
    Messages:
    2,509
    Location:
    ЭССР - Italy
    Re: Баг "Wrong mod detected"

    Надо еще посмотреть, что в папке MODS находится.
     
  3. -=RFF=-Avva

    -=RFF=-Avva Member

    Joined:
    Feb 11, 2009
    Messages:
    23
    Re: Баг "Wrong mod detected"

    Я уже скидывал содержимое корневой папки и папки MODS ранее Бармалу, надеюсь, он смотрел.

    Если надо - еще раз скину.
     
  4. -=RFF=-Avva

    -=RFF=-Avva Member

    Joined:
    Feb 11, 2009
    Messages:
    23
    Re: Баг "Wrong mod detected"

    Тут дело явно не в содержимом папки-мамки...
    А в том, что защита не только содержимое папок проверяет - а что-то еще в системе.
    Я же писал - после ребута если сразу запущу пару программ, а не Ил2 сразу (например, сначала запущу Maxthon) - то сразу получаю "Wrong mod detected" после проверки. Maxthon и другие проги 100% не лезут в папку Ила.

    У меня нечто подобное было с массовым включением ЧРТ=2 на серваках. Тогда у меня стояла Vista Ultimate x64, так вот было почти тоже самое: первый раз к серваку с включенным ЧРТ=2 я мог подключиться, второй раз (если выходил хоть раз из Ила) - уже нет, получал ошибку Timeout 1.
    Лечилось только перезагрузкой Висты.
    Единственное исключение было - под вистой я мог любые проги запускать перед стартом ила, первый раз я все равно нормально заходил на серваки с включенным ЧРТ=2.

    Поскольку ЧРТ=2 делал Медокс и надежды на исправление его косяка у меня не было - то я снес нафиг Висту и поставил WinXP x64.

    А тут надеюсь всё-таки на разработчиков.
    Именно из-за этого глюка я и не летал на ФХ уже месяц почти. Почитал новости - вроде что-то правили. А оказалось, что этот баг так и остался((( Вчера часик только полетал...
     
    Last edited: Mar 13, 2009
  5. --maty

    --maty Well-Known Member

    Joined:
    Jan 22, 2002
    Messages:
    5,707
    Location:
    Marseille, FRANCE
    Re: Баг "Wrong mod detected"

    Таки правили, и моя проблема с обнаружением неправильного мода - пропала. Видимо у тебя какойто другой косяк.
     
  6. barmal

    barmal Well-Known Member

    Joined:
    Jun 15, 2000
    Messages:
    620
    Location:
    Tomsk, Russia
    Re: Баг "Wrong mod detected"

    Есть еще один баг сейчас, возможно он влияет на тебя. Будет новый релиз там посмотришь.
     
  7. -=RFF=-Avva

    -=RFF=-Avva Member

    Joined:
    Feb 11, 2009
    Messages:
    23
    Re: Баг "Wrong mod detected"

    Спасибо за ответ, Бармал!

    Буду подождать.