Excel и формулы.

Discussion in 'Hardware and Software' started by Stefan, Jan 13, 2021 at 07:58.

  1. Stefan

    Stefan FH Beta Tester

    Joined:
    Feb 14, 2001
    Messages:
    19,047
    Location:
    Пивбар
    Excel 2010
    Понравилась мне идея -jaya- с премированием оценок для ребёнка.
    Ну там Депозит раз в неделю +50. 5-ка +10, 3-ка -5, 2-ка -10.
    Составил табличку в Excel с датами (A2-A32) и Депозит(B2-B32) - Предметы (C-H)
    Не хочется итог в B33 считать всё самому, но не получается сделать нормальную функцию.
    Хочется сделать всё на уровне Exel для наглядности.
    Сумма B2-B32 посчитана, вот теперь как в B33 добавить =ЕСЛИ C15=3, то =B33-5, а =ЕСЛИ D10=2 то B33=B33-10, =ЕСЛИ F3=4 то B33=B33, ну и соответственно Если=H20=5 то B33=B33+10.
    Понятно что посчитать B33 нужно для всей таблицы. И значения для С15, B33, D10, F3, H20 приведены для примера и понятно что расчет нужен для каждой ячейки . Считать по всему массиву нужно.
     
    Last edited: Jan 13, 2021 at 08:04
  2. Flk

    Flk Well-Known Member

    Joined:
    Aug 21, 2002
    Messages:
    10,135
    Location:
    Izhevsk
    Приделай в столбцах I-N... формулу (для I2, раскопипастить в остальные): =ЕСЛИОШИБКА(ЕСЛИМН(C2=5;10;C2=3;-5;C2=2;-10);0) и бери сумму по ним.
    MSO у меня нет, формула из Либры.
    Столбцы I-N для красоты можно скрыть.
    Пример.
     
    Last edited: Jan 13, 2021 at 16:54
    Stefan likes this.
  3. Stefan

    Stefan FH Beta Tester

    Joined:
    Feb 14, 2001
    Messages:
    19,047
    Location:
    Пивбар
    Ага. Спасибо. Работает. Пришлось делать через гугл т.к. в MSO 10 функции ЕСЛИМН нет.
     
  4. mcgru-

    mcgru- Well-Known Member

    Joined:
    Sep 21, 2000
    Messages:
    47,643
    Location:
    Tomsk, Russia
    +10 за "5" - мало :) надо +50.
    и -10 за "2" - тоже никак не стимулирует. ну, получил двойку - следующей пятёркой покрою убыток... ;)
    А надо: "ааа, бля, двойка! мнеж теперь двумя-тремя пятёрками её покрывать надо! нууу, нафиг, лучше б ен получал её!"
    :)

    я доче такой расклад установил:
    5: +50
    4: +10
    3: -10
    2: -100

    но жена оказалась против :(
    придётся втайне от жены :)
     
    -Shai- and Flk like this.
  5. Stefan

    Stefan FH Beta Tester

    Joined:
    Feb 14, 2001
    Messages:
    19,047
    Location:
    Пивбар
    Ну это же ты вечером сольфеджио ребёнку рассказываешь после 21 го Красноярска? Ну так у меня работа по МСК заканчивается. И тебя коты не хватают за жопу.